PDA

View Full Version : "GotTo First Unread Post" not working


~Sparklingflame~
09-22-2010, 04:56 PM
Mine s REALLY acting up. Has been for the past week or so. When I click on it, it will do one of the following:

Go to the first post
Go to a random spot in the middle of the thread and stay there
Stay on the top of the last page and after I scroll down after the page finishes loading, it will go back up to the top of the last page.

Is this just happening to me? Can we fix it?

Thnx! :)

~Sparklingflame~
09-27-2010, 12:22 PM
Still not working.

dimopoulos
09-27-2010, 01:11 PM
It depends on the browser you are using and on your connection to the internet.

If you are using IE then you are most likely to notice it instead of other browsers like Chrome or Firefox.

The technique is the same on all browsers. It is how the browser interprets it that makes it appear to not work.

Here is the scenario: To go to the new post the URL is constructed like this:

http ......... blah_blah.html#post12

That will get the focus on the anchor post12 (#post12) which is defined somewhere on the page - effectively the post you want.

Now if your browser loads things in a different order than normally you might end up for a very brief moment on the post you want but because an image or series of images on the posts above you manage to load, the page shifts downwards more and more. This is what makes it not work.

What you can do is click the icon and then once the page is loaded fully, click the refresh button. That will most likely cure the problem - the other solution is to use a different browser (which at times might not be a solution).

HTH

~Sparklingflame~
09-29-2010, 09:49 AM
Thanks. I use Firefox. Ive tried the refresh button and that didnt work Do I need to clear cookies or something? Like today if I go to the first unread post of the day, it will be the correct post. But lets say 50 posts have been posted since then it still takes me back to the original new post.